Titanium Community Questions & Answer Archive

We felt that 6+ years of knowledge should not die so this is the Titanium Community Questions & Answer Archive

Older version of Titanium developer for mac

Im using Leopard (not snow) and older iPhone SDK (Lastest iPhone SDK is only for snow leopard). Titanium Developer don't work with older iPhone SDK. It freezes when i choose mobile app. I think mobile SDK 1.0 will work, but i cant find it.

Installer always downloads lastest mobile sdk.

Is it possible to download older version somewhere?

— asked April 20th 2010 by Dominik Slavkovsky
  • iphine
  • leopard
  • mobile
0 Comments

7 Answers

  • Ok, i found the answer to my own earlier question… so, here it is for all WindowsHeads like me:

    You can download earlier versions of the Ti SDK from: http://builds.appcelerator.com.s3.amazonaws.com/index.html

    And to install it… you need to copy the SDK to: C:\ProgramData\Titanium\mobilesdk\win32

    This last step was the strange bit since I installed Ti in C:\Ti the SDK is not installed in the same folder… somehow, no matter where you install Ti, the SDK is installed in C:\ProgramData\Titanium...

    So, now we can enjoy older versions of Ti SDK :-)

    — answered December 24th 2010 by m m
    permalink
    0 Comments
  • Did you got any answer on this ? I also need an old version of Titanium.

    Thanks

    — answered December 20th 2010 by clement dufour
    permalink
    0 Comments
  • I am joining in on this question too… where do we get older more stable Ti sdk's? I hear 1.4 is pretty stable… help anyone?

    — answered December 23rd 2010 by m m
    permalink
    0 Comments
  • You can download old versions of the "Continuous" builds (nightly, development versions) from http://builds.appcelerator.com.s3.amazonaws.com/index.html. In the Branch drop-down list, select 1_4_x. The top-most 1.4.x build is internally called 1.4.3 and seems to be quite stable.

    Older than that, I don't know. I don't know that there's a repository of the older SDKs or TI Developer apps.

    — answered December 23rd 2010 by Tim Poulsen
    permalink
    0 Comments
  • Thanks a million for the link, Tim…

    I downloaded a zip file which contains a folder tree with version 1.4.3… now, how do install this old version? where do I copy it to?
    I thought I might be able to drop this new folder next to the existing 1.2 folder or 1.5 folder… i searched my current Ti folder, and I can't see a similar tree.. any idea where I need to put this version of the SDK?

    Thanks

    — answered December 23rd 2010 by m m
    permalink
    0 Comments
  • Thanks a million for the link, Tim…

    I downloaded a zip file which contains a folder tree with version 1.4.3… now, how do install this old version? where do I copy it to?
    I thought I might be able to drop this new folder next to the existing 1.2 folder or 1.5 folder… i searched my current Ti folder, and I can't see a similar tree.. any idea where I need to put this version of the SDK?

    Thanks

    — answered December 23rd 2010 by m m
    permalink
    0 Comments
  • Hi
    as it is provided above URL : http://builds.appcelerator.com.s3.amazonaws.com/index.html
    is not working, i didnt find any previous build locations as well.
    Can anybody share previous build versions of titanium sdk starting from 3.0 to older versions, as latest version 3.2 have lot of issues (IDE gets hang & emulator, simulator takes too much time to run app …)

    thanks

    regards,
    Srinivas

    — answered January 3rd 2014 by Srinu Vasu
    permalink
    0 Comments
The ownership of individual contributions to this community generated content is retained by the authors of their contributions.
All trademarks remain the property of the respective owner.